AADSTS500014 – Exchange Online Service Principal Disabled. Fix Disabled Service Principal for Outlook.office365.com

Modified on Mon, 14 Apr at 2:24 AM

AADSTS500014: Exchange Online Service Principal Disabled - The service principal for a Microsoft 365 resource is disabled. This may indicate that a subscription has lapsed or the administrator has disabled the application.

This error occurs when Microsoft 365 is unable to issue a token for Outlook because the corresponding service principal is disabled in the tenant.


Cause:

  • The Outlook (Exchange Online) service principal is disabled
  • The tenant's Microsoft 365 subscription has lapsed
  • The application was manually disabled in Microsoft Entra ID (Azure AD)

Resolution

  1. Log into the affected customer's Microsoft 365 tenant as an administrator
  2. Go to Microsoft Entra ID > Enterprise Applications
  3. Search for Office 365 Exchange Online (this maps to https://outlook.office365.com)
  4. Click on the application, and open Properties
  5. Ensure enabled for users to sign in is selected

If the tenant's subscription has expired, you may need to renew or re-assign licenses to restore access


If the service principal is missing entirely, Microsoft may need to restore it via a support request. You can also reference Microsoft Docs:

If you are unable to resolve the issue, contact support@sync365.app

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